NFT.io Temporary Downtime
Incident Report for Enjin
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 13:11 UTC
Investigating
Please be informed that NFT.io marketplace is temporarily inaccessible due to a technical issue. Updates will be provided as the team resolves the issue. Thank you for your patience.
Posted Jan 08, 2024 - 11:43 UTC
This incident affected: Marketplace (NFT.io).