Temporary Performance Issues on BTC, LTC, and DOGE Balances and Transactions

Incident Report for Enjin

Resolved

This incident has been resolved.
Posted Feb 07, 2024 - 11:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2024 - 07:57 UTC

Investigating

Users may experience issues on displaying balances and viewing transaction history as we work on a technical issue. Unsuccessful attempts may also be encountered on sending new transactions. Rest assured, all funds remain secure and unaffected as the team resolves the matter.

Thank you for your patience and understanding.
Posted Feb 07, 2024 - 01:56 UTC
This incident affected: Wallet (Enjin Wallet).