Issue receiving replies through our support ticketing system

Incident Report for Enjin

Resolved

We've successfully identified the root cause, and we have now resolved the issue.
If you're still waiting to hear back from our Support Team, please send us another email/reply.

We apologise for any inconvenience caused.
Posted Dec 27, 2021 - 10:35 UTC

Investigating

We are currently investigating an issue with receiving replies through our support form.
Posted Dec 27, 2021 - 09:52 UTC
This incident affected: Enjin Website (Support Ticketing).