Temporary Performance Issues on BTC, LTC, and DOGE Balances and Transactions
Incident Report for Enjin
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 08:05 UTC
Identified
Users may experience issues on displaying balances and viewing transaction history as we work on a technical issue. Unsuccessful attempts may also be encountered on sending new transactions. Rest assured, all funds remain secure and unaffected as the team resolves the matter.

Thank you for your patience and understanding.
Posted Jan 12, 2024 - 04:48 UTC
This incident affected: Wallet (Enjin Wallet).