Issue on Displaying Ethereum Wallet Balances

Incident Report for Enjin

Resolved

This incident has been resolved.
Posted Apr 02, 2024 - 04:14 UTC

Monitoring

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2024 - 01:45 UTC

Investigating

Users may experience issues on displaying Ethereum token balances as a certain service provider is working on an intermittent technical error. Rest assured, all funds remain secure and unaffected by this temporary display issue. Thank you for your patience and understanding.
Posted Apr 02, 2024 - 01:08 UTC
This incident affected: Wallet (Enjin Wallet).