Issue on Displaying Wallet Balances
Incident Report for Enjin
Resolved
This incident has been resolved.
Posted Dec 27, 2023 - 17:12 UTC
Identified
Due to a technical issue, users may encounter discrepancies in the balance currently displayed from the Enjin Wallet app. Rest assured that all funds are safe and the technical team is diligently working to resolve the display problem. Your patience and understanding is very much appreciated.
Posted Dec 27, 2023 - 16:23 UTC
This incident affected: Wallet (Enjin Wallet).