Metadata Service Outage Impacting NFT.io and Enjin Wallet

Incident Report for Enjin

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 06:41 UTC

Update

We are continuing to investigate this issue.
Posted Sep 02, 2025 - 04:07 UTC

Investigating

Metadata Service is currently unavailable and returning errors on NFT.io and in the Enjin Wallet app, including the Staking interface. The technical team is investigating the cause and working to restore normal functionality. Apologies for the disruption.
Posted Sep 02, 2025 - 03:51 UTC
This incident affected: Wallet (Enjin Wallet, Governance & Staking Interface) and Marketplace (NFT.io).