Efinity balances and assets not loading

Incident Report for Enjin

Resolved

This incident has been resolved.
Posted Jul 13, 2023 - 02:39 UTC

Investigating

The Enjin Wallet is currently facing technical difficulties with Efinity balances and assets not loading properly. The team is actively working to resolve the issue and restore normal functionality as soon as possible. For any issues related to this, please contact enjin.io/support.
Posted Jul 13, 2023 - 02:13 UTC
This incident affected: Wallet (Enjin Wallet).