Temporary Performance Issues on NFT.io
Incident Report for Enjin
Resolved
This incident has been resolved.
Posted Jan 05, 2024 - 07:49 UTC
Identified
Users may experience degraded performance while navigating and transacting in NFT.io marketplace due to a technical difficulty currently being resolved by the team.

An update on the progress of resolution will be provided accordingly.
Posted Jan 03, 2024 - 02:21 UTC
This incident affected: Marketplace (NFT.io).