Early Governenance Rewards Not Displaying on Enjin Wallet
Incident Report for Enjin
Resolved
This incident has been resolved.
Posted Feb 17, 2024 - 00:37 UTC
Identified
Reports of users not seeing their latest early governance reward tranche in the Enjin Wallet if they don't already hold an active stake balance. The issue is recognized and a hotfix is being prepared. Stand-by for further updates.
Posted Feb 14, 2024 - 10:10 UTC
This incident affected: Wallet (Governance & Staking Interface).