Issue receiving replies through our support ticketing system
Incident Report for Enjin
Resolved
We've been working with our support ticketing provider, and this incident is now resolved.

If you have not received a reply from Enjin Support within the next business day, please send us a new email, and we will get back to you as soon as possible We apologise for any inconvenience this may have caused.
Posted May 03, 2021 - 18:40 UTC
Investigating
We have been informed that our support ticketing provider is currently experiencing an issue wherein customer replies are not coming through. We ask that you please be patient whilst our support ticket provider resolves these issues. In the event that you do not receive a response from our support team within the next business day, please send a follow-up email as it may have been missed due to this incident.
Posted May 03, 2021 - 09:53 UTC
This incident affected: Support (Support Ticketing).