NFT.io (beta) Maintenance

Incident Report for Enjin

Resolved

We are pleased to announce that beta.nft.io is now back online and is operational. Thank you for your patience during the maintenance period.
Posted Jun 08, 2023 - 16:24 UTC

Update

Claiming existing Efinity Beams is back to operational. On the other hand, NFT.io remains temporarily offline due to ongoing maintenance. Thank you for your patience.
Posted Jun 07, 2023 - 02:04 UTC

Update

Maintenance on beta.nft.io is still ongoing. Thank you for your patience.
Posted Jun 04, 2023 - 12:06 UTC

Identified

We are actively performing maintenance on NFT.io, https://beta.nft.io will not be accessible at the moment. Thank you for your patience.
Posted May 31, 2023 - 23:36 UTC
This incident affected: Marketplace (NFT.io).