ENJ Staking Balance Display Bug (On-Chain Balances Unaffected)

Incident Report for Enjin

Resolved

This incident has been resolved.
Posted 23 days ago. Jun 16, 2025 - 08:18 UTC

Investigating

We are aware of an issue causing incorrect ENJ values to be displayed to users staking with Enjin Wallet. The team is working on a fix. Please be aware the issue is only visual, and on-chain balance is not affected.
Posted 26 days ago. Jun 13, 2025 - 01:06 UTC
This incident affected: Wallet (Governance & Staking Interface).