ENJ/EFI Token Claim Processing Temporarily Unavailable

Incident Report for Enjin

Resolved

The ENJ/EFI token claims functionality has now been re-enabled.
Posted Dec 02, 2025 - 08:12 UTC

Investigating

The ENJ/EFI token claims are temporarily suspended while the team investigates a potential issue affecting the process. This pause is precautionary and ensure the safety and integrity of user transactions.
The investigation is underway and updates will be shared as soon as more information is available.

Thank you for your patience and understanding.
Posted Nov 25, 2025 - 07:58 UTC
This incident affected: Wallet (Token Migration).