Visual Discrepancy on BTC, LTC, and DOGE Balances
Incident Report for Enjin
Resolved
This incident has been resolved. For any related concerns, kindly get in touch via support@enjin.io.
Posted Jan 08, 2024 - 06:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2024 - 00:42 UTC
Investigating
Users may experience issues on displaying balances as we work on a technical issue. Rest assured, all funds remain secure and unaffected by this temporary display issue.

Thank you for your patience and understanding.
Posted Jan 05, 2024 - 08:28 UTC
This incident affected: Wallet (Enjin Wallet).