Reports of errors and performance decrease in the Enjin Wallet

Incident Report for Enjin

Resolved

This incident has been resolved. We apologise for any trouble that was caused.
Posted May 01, 2022 - 12:43 UTC

Investigating

We're investigating reports of errors and performance decreases in the Enjin Wallet application. We apologise for any inconvenience and trouble caused during this time.
Posted May 01, 2022 - 12:29 UTC
This incident affected: Wallet (Enjin Wallet).