Beam Claims Temporarily Unavailable

Incident Report for Enjin

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 09:56 UTC

Investigating

Beam claims are temporarily unavailable at this time.

Users may be unable to claim Beams during this period. The issue is currently being investigated, and further updates will be provided as more information becomes available.
Posted Aug 20, 2026 - 09:30 UTC
This incident affected: Wallet (Beam Claim).