Issue on Displaying BTC Balance

Incident Report for Enjin

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 08:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2025 - 07:48 UTC

Identified

The issue has recurred and currently being coordinated with pertinent service providers.
Posted Feb 17, 2025 - 00:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2025 - 08:01 UTC

Identified

Due to a technical issue, users may experience errors when viewing their BTC balance and transaction history on the Enjin Wallet app.

Rest assured, all funds remain safe, and the technical team is actively working to resolve the display issue. Your patience and understanding are greatly appreciated.
Posted Feb 15, 2025 - 01:55 UTC
This incident affected: Wallet (Enjin Wallet).