Ethereum Transaction Backlog
Incident Report for Enjin
Resolved
This incident has been resolved.
Posted Dec 30, 2019 - 17:31 UTC
Monitoring
We have implemented a fix for an Ethereum Transaction Backlog, we are continuing to monitor the backlog.
Posted Dec 30, 2019 - 16:33 UTC
This incident affected: Explorer (Ethereum Mainnet Explorer, Mainnet API) and Wallet (Enjin Wallet).